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Introduction

Apogee’s Maestro software application provides control, routing and low-latency mixing functionality for Apogee 
hardware interfaces connected to an Apple Macintosh computer. Maestro gives you control of your Apogee 
system by allowing you to adjust hardware settings, configure routing between hardware and software I/O, and 
create low-latency mixes of hardware I/O paths and software outputs.

As of Maestro version 1.3, the following Apogee hardware interfaces are supported:

• Duet Firewire Interface
• Ensemble Firewire Interface
• Symphony PCI card(s) with AD16X,DA16X, Rosetta 800 or Rosetta 200 connected
• Symphony Mobile Express/34 card with AD16X,DA16X, Rosetta 800 or Rosetta 200 connected
• MiniFW card for Apogee MiniMe and MiniDAC interfaces

Computer requirements:
•  OSX 10.4.10 or above
•  Apple Macintosh PowerPC or Intel CPU, 1.0GHz or higher, 1GB of RAM required, 2GB recommended
•  Supported Apogee hardware and all necessary drivers and OS X updates must be installed, tested and 

operating correctly

Installation:
To install Maestro, unzip the file (if downloaded) or insert the CD that accompanies Apogee hardware, and 
follow the on-screen instructions provided by the installer.
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Maestro consists of two main windows, Maestro Control and Maestro Mixer; routing and low latency mixer settings are 
made in the Maestro Mixer window, while settings such as clock source and unit-specific settings (mic-pre gain, Sym-
phony VBus) are made in the Maestro Control window.

Maestro also includes functionality for checking software and firmware versions, choosing Mixer key commands, and sav-
ing and recalling routing, mixer and control configurations. 

The contents of both the Control and Mixer windows change according to the Apogee hardware selected in the Interface 
drop down menu.

Maestro Control - Ensemble  

4. For a complete description of the settings displayed on the Maestro Control window when an Ensemble is chosen in 
the Interface drop down menu , please consult the Ensemble User’s Guide, pages 14-17.

Maestro Control - Duet   

4. For a complete description of the settings displayed on the Maestro Control window when a Duet is chosen in the 
Interface drop down menu , please consult the Duet User’s Guide, pages 10-17.

Maestro Control - Symphony/Symphony Mobile

1. Interface Drop Down menu – The Interface drop down menu, found in the upper left corner of each Maestro window, 
is used to select the Apogee interface whose settings are displayed in that window. Once selected, an icon repre-
senting the interface appears at the top of the window. When hardware connected to a Symphony card is selected, 
Interface names are displayed in the following format:

2. Identify Unit – This feature is disabled when interfaces connected via Symphony/Symphony Mobile are selected.

3. Clock Source Select - This drop down menu is used to set the clock source of the selected interface to Internal or 
External. When set to Internal, the selected interface derives clock from an internal crystal; when set to External, 
clock source selection varies according to the digital input options of each Apogee interface, as described below.

 Rosetta 800/200 – when set to External, the specific source (ADAT/SMUX, AES or Word Clock input) must be 
manually selected on the Rosetta’s front panel.

 AD16X – when set to External, the AD16X accepts clock from its Word Clock input.
 DA16X – when set to External, the specific source, either word clock or digital input, must be manually selected 

on the DA16X’s front panel.

  This setting is grayed out when the clock source is automatically set by the hardware system. For example, in a multi-
interface Symphony PCI/Mobile system, Clock Source Select is greyed out when any but the first interface con-
nected directly to the Symphony card is selected in the Interface drop down menu.

Overview Overview

Symphony card to which 
the unit is connected

Unit model and Routing (AD-DA16X) 

Unit number
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Overview

Maestro Control - Symphony/Symphony Mobile 

VBus - Apogee’s VBus creates virtual hardware buses to allow the routing of signals within one audio application or 
between different audio apps. For example, it’s possible in Logic Pro to record a submix of multiple audio tracks onto a 
new audio track as described below - not possible without VBus. It’s also possible to route between two audio apps by 
selecting a VBus output in the source app and a VBus input in the destination app.

 To engage VBus and specify the number of desired buses, open Apogee’s Maestro application, select one of 
the Apogee interfaces connected to the Symphony PCI card, and open the Maestro Control Panel. In the VBUS 
Selections drop down menu, select the number of virtual buses desired. As these buses don’t use much CPU power, 
the only reason to select fewer buses would be to maintain order in the I/O lists of your audio apps. Up to 32 Vbuses 
per Symphony PCI card are possible

 In order for VBus I/O to appear in your audio application’s I/O list as VBus In 1-2, 3-4, etc, it’s necessary to specify 
the use of the Symphony driver’s names in the applications’s I/O list. For example in Logic Pro, open Audio>Audio 
Configuration>View>I/O Labels and Option-click on all the I/O found under the Driver’s I/O Label column.

 As an example of how to use VBus, let’s record a submix of drums onto a new stereo audio track in Logic Pro.
 
 Open Maestro and select 8 Channels under the VBus Selections menu.
 In Logic’s Track Mixer, set the outputs of the individual drum audio tracks to VBout 1/2
 Create two audio tracks (or one stereo track) and set their inputs to VBin 1 and VBin 2.
 Record-enable the new track and commence recording – the new track will record the mix of the individual drum 

tracks.

Performance Tuning allows the adjustment of Symphony driver buffers to take advantage of the latest Intel Macs’ 
increased CPU power. 

Set Performance Tuning to High Performance when using Symphony on an Intel Mac; this reduces buffer sizes 
and ensures the lowest latency through the Symphony system. 

Set Performance Tuning to Standard when using Symphony on G5 PowerPC Macs. Though Symphony buffers are 
set higher, latency is still quite low.

Performance Tuning is set in addition to the buffers typically found in digital audio applications. If audible clicks and 
pops are encountered, first raise the driver buffer size in the audio application. Apogee’s extensive testing of this 
driver indicates that software buffers will “run out” before the Symphony driver buffers controlled by Performance 
Tuning. If problems persist set Performance Tuning to Standard.

Maestro Control - MiniFW

When a MiniDAC connected via a MiniFW card is selected in the Interface drop down menu, the unit is displayed but 
no user functions are available. The MiniFW check box indicates that the MiniFW card is receiving a proper clock.

When a MiniMe connected via a MiniFW card is selected in the Interface drop down menu, the unit is displayed and 
a UV22HR check box is displayed. Checking this box enables UV22HR processing (Apogee’s industry leading 24 to 
16-bit dithering algorithm) on the FireWire output to the software application.

Overview
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Input PaneMaestro Mixer Window

Input/Output Panes

 The Input and Output Routing panes consist of an intuitive routing grid on which connections between hardware and 
software I/O are depicted and modified visually. 

 Connections are depicted by grey connection icons  at the intersection of a hardware I/O column and a soft-
ware I/O row.  To modify a connection, place the curser over the grid at the intersection of the desired hardware I/O 
column and software I/O row, and click on the highlighted grid position; the grey connection icon will shift into the new 
position to indicate that the desired connection has been made.

 
 As an example, the default state of the Input routing pane with an Ensemble connected is shown in figure 1 . Ensem-

ble’s hardware inputs are displayed across the top of the grid, while software inputs are displayed to the left of the 
grid. The grey connection icons, labelled L and R, are placed such that hardware inputs Analog In 1 and 2 are con-
nected to software Input Analog 1/2, hardware inputs Analog In 3 and 4 are connected to software Input Analog 
3/4, and so on.

Input Pane

 The Input pane serves to connect hardware inputs to software inputs, as shown in figure 2 . The following controls are 
found in the Input pane:

1.  Interface menu , Identify Unit – These controls, found at the top of the Input, Output and Mixer panes, are identical 
to those found in the Maestro Control window described on page 2. 

2. Matrix – The settings in these drop down menus define how software inputs are formatted in the routing grid:
  Mono - software inputs are formatted as Mono signal paths.
  Stereo - software inputs are formatted as Stereo signal paths.
  Off - the signal path is deactivated.

3.  Input – This column displays the software inputs available for routing. Software input names may be modified by 
clicking on the triangle to the left of the Matrix to reveal a text entry box. For these names to appear in your audio 
application’s I/O list, it’s necessary to specify this in the audio app. For example in Logic Pro, open Audio>Audio 
Configuration>View>I/O Labels and Option-click on all the I/O found under the Driver’s I/O Label column

4.  (Analog, Hardware) In – This row displays the hardware inputs available for routing. 

5.  Mixer A In, Mixer B In – It’s possible to route the output of either the A or B mixer (found in the Mixer pane) back into 
the software application. For example, when hardware synths are connected to the hardware inputs of an Apogee 
interface, it’s possible to mix these synths using the Maestro mixer and record the mix in your software application by 
assigning either the Mixer A In or Mixer B In to a software path.

  

figure 2

figure 1
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Output Pane

 The Output routing pane is functionally similar to the Input pane, but used to make connections between software and 
hardware outputs, as depicted below.  Software outputs are displayed to the left of the grid, and hardware outputs are 
displayed across the top of the grid.

1.Matrix – The settings in these drop down menus define how software outputs are formatted in the routing grid:
  Mono - software outputs are formatted as Mono signal paths.
  Stereo - software outputs are formatted as Stereo signal paths.
  Off - the signal path is deactivated.
  (hardware input) Direct - this setting, unique to the Output pane, provides a signal path to route hardware 

inputs directly to hardware outputs. For example, it’s possible to route Ensemble’s 8 analog inputs to the optical 
output while routing the optical input to the 8 analog outputs. This configuration is shown in the lower routing page 
example shown at right.

2.  Output – This column displays the software outputs available for routing. Software output names may be modified 
by clicking on the triangle to the left of the Matrix to reveal a text entry box. For these names to appear in your audio 
application’s I/O list, it’s necessary to specify this in the audio app. For example in Logic Pro, open Audio>Audio 
Configuration>View>I/O Labels and Option-click on all the I/O found under the Driver’s I/O Label column.

3. (Analog,Hardware) Out - This row displays the hardware outputs available for routing. 

 
 

Maestro Mixer Window Output Pane

1

2

1 2

3

Output Signal path: Logic> Maestro> Ensemble

3
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1a
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Maestro Mixer Window

Working with the Input, Output and Mixer Panes

 While configuration of Input/Output routing is quite intuitive, there are a few details to be aware of:

 One Hardware Input, Multiple Software Inputs - In the Input pane it is possible to route one hardware input to 
multiple software inputs simply by clicking down the desired hardware input column and across the desired software 
inputs, as shown at right. For the recording situation where one microphone is routed to several software tracks (say, 
when recording backing vocals), the necessary changes are accomplished more quickly in the Input routing pane 
than in your software application.

 One Software Output, Multiple Hardware Outputs - In the Output pane it is possible to route one software output 
to multiple hardware outputs by holding down the Control key while clicking across the desired software output row 
and under the desired hardware outputs, as shown at right.

 AD16X - Standard Routing - When an AD16X in Standard routing mode is selected in the Interface menu, the Out-
put pane is blank, reflecting the fact that there are no signal paths from software outputs to AD16X outputs while it is 
set to Standard routing.

 DA16X - Standard Routing - Likewise, when a DA16X is selected, the Input pane is blank; there are no signal paths 
from DA16X inputs to software inputs while the interface is set to Standard routing.

 AD16X - Advanced Routing - When the AD16X is set in Advanced routing, the Input pane is used to route the 
AD16X’s analog inputs to software inputs, and the Output pane is used to route software outputs to the AD16X’s AES 
and ADAT/SMUX outputs.

 DA16X - Advanced Routing - When the DA16X is set in Advanced routing, the Input pane is used to route the 
DA16X’s AES or ADAT/SMUX digital inputs to software inputs, and the Output pane is used to route software outputs 
to the DA16X’s Analog outputs.

 MiniFW - When a MiniMe or MiniDAC connected via a MiniFW card is selected, the input and From Mac meters   
 display their associated signals, but mixing functionality is disabled. The Input and Output panes are disabled.

 Duet - When a Duet is selected in the Interface menu, the Mixer pane displays a fully functional two input mixer. The   
 Input and Output panes are also disabled.

1

1

2

2

Maestro Mixer Window



APOGEE ELECTRONICS

12

Maestro – User’s Guide APOGEE ELECTRONICS

13

Maestro – User’s Guide

Before describing the functions of Maestro’s Mixer pane, a bit of background information concerning latency and comput-
er-based digital recording setups will help to better understand these Mixer functions.

When recording with most computer-based digital audio applications, the delay between the input and output of the re-
cording system can disturb the timing of musicians recording their performance while listening to the output of the system. 
This delay, known at latency, means that the musician hears the notes he produces a matter of milliseconds after having 
produced them. As anyone who has spoken on a cell phone call with echo or delay knows, relatively short delays can 
confuse the timing of any conversation, spoken or musical.

To illustrate the effect of latency, figure 1 depicts the typical signal path of a vocal overdub session. A vocalist sings into a 
microphone, which (after pre-amplification) is routed to an analog to digital converter, then to the audio software applica-
tion for recording. In the software app, the vocalist’s live signal is mixed with the playback of previously recorded tracks, 
routed to a digital to analog converter, and finally to the vocalist’s headphones. A slight delay accumulates at each conver-
sion stage, while a much greater amount of delay occurs through the software app, resulting in the vocalist hearing his 
performance in the headphones up to several milliseconds later. 

Maestro Mixer – An Overview Maestro Mixer – An Overview

By modifying the signal path as illustrated in figure 2, it’s possible to provide the vocalist a headphone monitoring signal 
with a much shorter delay. First, the signal being recorded (in this case, a vocal mic) is split just after the A/D stage and 
routed to both the software app for recording and directly back to the hardware outputs without going through the latency-
inducing software app; this creates a low-latency path from mic to headphones. But in order to overdub, it’s necessary 
to mix this direct path with tracks being played back from the software app. By creating a DSP mixer in hardware, the 
required mixing may be accomplished. Indeed the mixing “engine” of Maestro’s Mixer  “resides” on DSP found in Apogee 
hardware; the actual Mixer pane may be thought of as a software remote control for this DSP hardware mixer.

Before this theoretical examination of low-latency mixing slows you down, here are a few simple guidelines for working 
with a software app (in this case, Apple Logic Pro) and Maestro’s mixer.

1. Configure Logic Pro so that the track to which you’re recording will mute 
when Record is engaged but will play back when Record is disengaged (even 
if the track is record-enabled). Thus, when actual recording is taking place the 
performer only hears the low-latency path in his headphones, but hears play-
back of the track (for punching in) before and after Record is engaged. This is 
accomplished quite simply by unchecking the Software Monitoring box in the 
Audio Hardware and Drivers page.

2. Set both the Maestro and Logic channel faders through which the recorded 
signal is passing to 0 dB, to avoid changes in level between recording and 
playback. Rather than adjust these faders, adjust playback faders to achieve 
the desired balance between playback and the signal being recorded. Also set 
the Maestro From Mac and To Hardware faders to 0 dB. By “zeroing out” the 
Maestro mixer and making all level changes in the software app mixer where 
practicable, operation is quite a bit more straightforward.

Figure 1

Figure 2
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Mixer Pane

As described in the previous section, the Maestro mixer serves to blend hardware inputs with software outputs (playback), 
and route the mix directly to hardware outputs, as depicted below.

1.  Mixer Select (A-B) –  This drop down menu selects between the two available mixers per hardware interface. (Note 
that Duet offers only one mixer, thus the Mixer Select (A-B) drop down menu doesn’t appear when Duet is selected.)

2.  Input channels –  Hardware inputs of the selected interface (under the Interface menu) are the source for the Mae-
stro mixer inputs.

3. Pan – This slider pans the input signal between the left and right sides of the Maestro mixer output.

4. Pan value window – The pan value (where full left is designated <64, center is <0> and full right is 64>) is displayed 
in this window.

5. Level fader – This slider set the level at which the input signal is mixed to the Maestro mixer output.

6. Level value window – The Level value (between “Muted” and +6) is displayed in this window

7. Meter – This bargraph style meter displays the pre-fader input level.

8. Mute – This button mutes the input channel.

9. Solo – This button solos the input channel, thereby muting all channels whose Solo buttons are not engaged.

Maestro Mixer Window Maestro Mixer Window

10. From Mac – This stereo input channel provides level control, metering and mute/solo functions for the signal from 
the software application containing playback . Match the software application’s mixer output and the From Mac drop 
down menu selection. In most cases the software mixer output and From Mac are both set to outputs 1-2.

11. To Hardware – This stereo output channel provides a level fader, metering and a routing drop down menu for control-
ling the stereo output of the Maestro mixer. Select the hardware output at which the Maestro mixer output should 
appear. Again, in most cases To Hardware is set to hardware outputs 1-2

 If To Hardware is set to None, the Maestro mixer is removed from the signal path, and the connection between the 
software and hardware output is determined in the Output routing pane. When To Hardware is set to any hardware 
output, the resulting routing is displayed in the Output pane as Mixer Out.

(Symphony PCI  only) Maestro mixing may be accomplished  from any hardware input to any hardware output as long as 
the hardware is connected to the same Symphony PCI card. 

 For example, in a system that consists of an AD16X and DA16X connected to Symphony PCI card #1 and a Rosetta 
800 connected to Symphony PCI card #2, any AD16X input may be mixed to any DA16X output, any Rosetta 800 
input may be mixed to any Rosetta 800 output, but the AD16X inputs may not be mixed to the Rosetta 800 outputs.
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Maestro> About Maestro
Selecting this menu item opens the panel shown below, which indi-
cates various software and firmware versions. 

Maestro> Preferences 
Selecting this menu item opens the Preferences panel, in which mixer control actions may be defined.

 

Rotary Controls
 Mouse motion – This selection defines the motion of the 

mouse required to adjust rotary controls such as Ensemble 
Mic Pre gain.

 Fine adjust key – This selection defines the key command to 
make fine adjustments to any rotary control. 

Fader Controls
 Fine adjust key - This selection defines the key command to 

make fine adjustments to any fader control. 
 0dB key – This selection defines the key command to set the 

fader to 0 dB when clicking in the level value window.
 Ungroup faders - This selection defines the key command  

to adjust one side of the stereo From Mac and To Hardware 
faders.

Pan Controls
 Fine adjust key - This selection defines the key command to 

make fine adjustments to any pan control.
 Center - This selection defines the key command to set the 

pan control to <0>, or center, when clicking in the pan value 
window.

Other
 Mute/Solo all - This selection defines the key command to 

engage all Mutes or Solos when clicking on the Mute or Solo 
buttons.

Duet Preferences
 Launch Maestro automatically when connecting Duet - 

When this box is checked, Maestro is launched automatically 
when Duet is discovered on the Mac’s FireWire bus.

 Enable Duet Pop-ups - When this box is checked, encoder 
pop-ups appear on the Mac desktop.

Maestro – Menu by Menu

Maestro> Hide Maestro
 Choosing this menu item hides the Maestro application.
Maestro> Hide Others 
 Choosing  this menu item hides all other open applications.
Maestro> Show All
 If Hide Others has been previously selected, choosing  this menu item reveals all open 

apps in the Finder.
Maestro> Quit Maestro 
 Choosing  this menu item closes the Maestro program.

File:
File> Open
 Choose this menu item to navigate to a previously saved Maestro configuration file and 

open it.
File> Open Recent 
 Choose this menu item to re-open a recently opened Maestro configuration file.
File> Close Window 
 Choose this menu item to close the “active”, or up-front, window.
File> Save 
 Choose this menu item to save the current settings of all windows.
File> Save As
 Choose this menu item to save the current settings of all windows as a newly named 

file.

Tools:
Tools> Maestro Control
 Choosing this menu item opens the Maestro Control window
Tools> Maestro Mixer
 Choosing this menu item opens the Routing/Mixer window
Tools> Reset Symphony Clocking
 In certain instances Apogee interfaces can’t be detected until the clock setting of the 

first interface has been reset. After choosing Reset Symphony Clocking, a dialog box 
appears allowing the reset of  clock source on the first interface to Internal or Exter-
nal.

Tools> Refresh Connections
 Choosing this menu item re-scans computer connections for connected Apogee hard-

ware.
Tools> Reset Mixer
 Maestro mixers may be reset with this menu item; choose Reset Displayed to reset 

the mixer displayed in the Maestro Mixer window; choose Reset All to reset all mixers.
Tools> Reset Routing
 Choosing this menu item resets the Input and Output panes to a “pass through” con-

figuration, where hardware and software I/O are connected on a one to one basis.

Window:
Window> Minimize
 Choosing this menu item minimizes the up front window to the OS Dock.
Window> Zoom
 Choosing this menu item maximizes the size of the active Maestro window.
Window> Bring All to Front
 Choosing this menu item places all Maestro windows in front of other applications’ 

windows.
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